Jump to content
  • 0
TheRealRickyP

Phoenix Launcher will not work.

Question

First, I downloaded the launcher from the Phoenix Network website. When I run the desktop shortcut (as admin), it says "LOADING" on a transparent foreground. I left it for 20 minutes and it still said loading. I tried starting it many times with the same result. 

Freezes like this.

Picture_1.PNG

 

Then, I tried downloading the launcher zip file from a link provided on this forum.  After unzipping the file, when I run phoenixlauncher.exe (as admin) the login screen does appear but everything in the window is frozen. I cannot type in the fields and none of the buttons work. 

Freezes like this.

Picture 2.PNG

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...